Uploaded image for project: 'Hippo Site Toolkit 2'
  1. Hippo Site Toolkit 2
  2. HSTTWO-4208

More clear attribute names for the manageContent tag

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.2.0
    • Component/s: None
    • Labels:
      None
    • Similar issues:
    • Story Points:
      1
    • Epic Link:
    • Processed by team:
      Tiger
    • Sprint:
      Tiger Sprint 175

      Description

      When reviewing ESSENTIALS-1108 I noticed that not all attributes of this tag do have very clear names. I suggest two changes to make it more clear for developers what their purpose is.

      • rename the "document" attribute to "hippobean", which is more clear and in line with other tags like the hst.link tag
      • to use "componentParameter" correctly you must check code or documentation. What you set with this parameter is the name of the parameter of a component that should contain the content path to the new document. What about renaming it to contentPathParameterName? I admit this name is a bit long but... it is very descriptive!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                bleunis Bert Leunis (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: