Uploaded image for project: 'Hippo Site Toolkit 2'
  1. Hippo Site Toolkit 2
  2. HSTTWO-3789

Drop dependencies for stax api and implementation (not longer needed since Java 6, duh)

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.2, 4.1.0
    • Component/s: None
    • Labels:
      None
    • Similar issues:
    • Processed by team:
      Platform
    • Sprint:
      Platform Sprint 138

      Description

      geronimo-stax-api_1.2_spec and stax:stax implementation are outdated and no longer needed since Java 6.
      Furthermore, the stax2-api and woodstox implementation versions should be brought and kept in sync with with the versions the current cxf version expects.
      Current cxf 3.1.6 expects: stax2-api 3.1.4 (= 3.1.1) and woodstox-core-asl 4.4.1 (=4.2.0).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                adouma Ate Douma
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: