Uploaded image for project: '[Read Only] - Hippo Repository'
  1. [Read Only] - Hippo Repository
  2. REPO-397

Validate Hippo repository.xml files against JackRabbit repository-2.0.dtd (instead of 1.5.dtd)

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.20.12, 2.21.06, 2.22.05, 2.23.01-alpha
    • Fix Version/s: 2.23.02-alpha
    • Component/s: None
    • Labels:
      None
    • Similar issues:

      Description

      I believe that Hippo repository.xml files should validate against the latest version of JackRabbit DTD:
      <!DOCTYPE Repository PUBLIC "-//The Apache Software Foundation//DTD Jackrabbit 2.0//EN" "http://jackrabbit.apache.org/dtd/repository-2.0.dtd">

      Currently, this version is used:
      <!DOCTYPE Repository PUBLIC "-//The Apache Software Foundation//DTD Jackrabbit 1.5//EN" "http://jackrabbit.apache.org/dtd/repository-1.5.dtd">

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jsheriff Junaidh Kadhar Sheriff
                Reporter:
                mtricot Mickaƫl Tricot (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: