Uploaded image for project: 'Hippo Repository'
  1. Hippo Repository
  2. REPO-1227

On 7.9, hippostd:modify instruction with $name doesn't work on subnodes any more

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.26.13
    • Labels:
    • Similar issues:

      Description

      In a use case where a folder's template below /hippo:configuration/hippo:queries/hippo:templates has subnodes (e.g. a default document to be created too), the $name instruction on these subnodes does not work on 7.9.

      This used to work on 7.8 (I verified that)

      See attached screen shot.

      Reproduction

      • Create 7.9.7 project with Essentials, install news feature
      • Create new-news-folder-with-document template query (attached)
      • Configure it on a content folder
      • Execute it

      Expected: the document node has the same name as it's parent folder
      Actual: the document node is 'document', unchanged from template

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jhoffman Jeroen Hoffman
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: