Uploaded image for project: 'Hippo Site Toolkit 2'
  1. Hippo Site Toolkit 2
  2. HSTTWO-3952

Resource bundle registry not invalidated on replication / JCR change

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 4.2.0
    • Fix Version/s: 4.2.1
    • Component/s: None
    • Similar issues:
    • Story Points:
      0.5
    • Flagged:
      Flagged
    • Processed by team:
      Platform
    • Sprint:
      Platform Sprint 154

      Description

      When using the replication addon [1], resource bundles are moved correctly from one repository to another. However, sites that run on the target repository do not show any changed resource bundle values.

      This (most probably) is caused by the fact that the resource bundle registry is invalidated only on Hippo workflow events, not on JCR events.

      This is also visible if a value is changed using Console, like so:

      • build/run archetype project with feature "Simple content".
      • the local site shows "©2017" in the footer
      • in Console, change /content/documents/administration/labels/global/global/resourcebundle:messages

      Expected: site shows the changed value
      Actual: site still shows "©2017"

      [1] https://www.onehippo.org/library/enterprise/enterprise-features/replication/replication-overview.html

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jhoffman Jeroen Hoffman
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: