Uploaded image for project: '[Read Only] - Hippo Plugins'
  1. [Read Only] - Hippo Plugins
  2. HIPPLUG-1276

Contentblocks: multiple field not refreshing after hitting save (not save and close)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Do
    • Affects Version/s: content-blocks-2.1.1, content-blocks-2.1.2
    • Fix Version/s: None
    • Component/s: plugins-content-blocks
    • Labels:
      None
    • Similar issues:

      Description

      Following occurs in hippo archetype 10.2.0 and also in enterprise release 10.1.1

      Issue:
      When hitting save (not save and close) when editing a contentblock with a multiple property field and then reediting the fields by deleting them or trying to add more the fields are not refreshed.
      After hitting save and close the fields that were deleted are deleted.

      Reproduction path:
      basic archetype setup

      • open the hippo archetype
      • add contentblocks and simple content with essentials
      • add contentblocks to simple content with essentials
      • add to that specific contentblock a multiple string field

      Document reproduction path

      • create a document with that contentblock
      • edit the document
      • add contentblock to the document
      • add several specific items for that contentblock in the multiple string field
      • hit Save
      • try to delete some of the items in the multiple string field -> result block isnt refreshed
      • Hit save and close
      • see that now the fields are deleted

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Matthijs Matthijs Tolkamp
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: