Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-9721

Content blocks: Change not visible in the CMS before publishing (with patch)

    XMLWordPrintable

    Details

    • Similar issues:
    • Story Points:
      1
    • Sprint:
      Turing Sprint 120, Turing Sprint 121
    • Ticket type:
      Support (Billable)

      Description

      On the latest 7.9 and 10.1 archetypes, on the CMS reproduce the following steps:

      1. Create a new compound type (CompoundA) with a String field.
      2. Create another new compound type (CompoundB) that has a content-block field using the CompoundA field. It is possible to do it either via:
      3. Create a new document type (DocTypeA) containing a field of type CompoundB
      4. Create a new document of type DocTypeA, add some content to it and publish it
      5. Edit the document, make some changes on the string, save and close it.
        • Expected result: You can see these changes highlighted
        • Actual result: The changes are neither shown nor highlighted

      Updated: It is possible to reproduce the issue on 10.1 archetype:
      *content-blocks version: 2.2.0-SNAPSHOT
      *CMS version: 3.2.0-SNAPSHOT

      In case of adding a content-block field directly to a document type, the bug does not occur.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                llemos Luís Pedro Lemos
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: