Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-9594

console copy dialog does not report error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: 3.0.1
    • Fix Version/s: None
    • Component/s: console
    • Labels:
      None
    • Similar issues:

      Description

      Noticed during the training. Reproduction path:

      • set up new project using the archetype
      • install a content feature, e.g. the News feature
      • after rebuild copy this node:
        /hst:hst/hst:configurations/hst:default/hst:catalog/essentials-catalog/banner

      to this path:
      /hst:hst/hst:configurations/common/hst:catalog

      Result: the action fails, but no error message is given. You think your action succeeded, but hey, where is the copied node? There is a message in the log, but that is overlooked easily of course:

      [INFO] [talledLocalContainer] 16.10.2015 12:49:38 ERROR http-nio-8080-exec-2 [DefaultCopyHandler.startNode:88] Unable to create node from NodeInfo NodeInfo[banner[0](type=hst:containeritemcomponent, mixins=[])]: No applicable child node definition

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              bleunis Bert Leunis (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: