Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-9506

No error is shown when adding property (date) with empty value to prototype node

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 4.1.0
    • Component/s: console
    • Similar issues:
    • Processed by team:
      Platform
    • Sprint:
      Platform Sprint 133

      Description

      In the console go to a prototype node like for example [1]. Install the news feature on the archetype to get this config. If you add a date property there (myhippoproject:date) with no value, the property is not added. The "Write changes to repository" button turn red though, and it seems you can save the property. No errors in the log either. Alas, nothing is saved and you start questioning your state of mind. This can be prevented by showing a a proper error message. NB: if you give it a value, e.g 0001-01-01T13:00:00.000+01:00, the property is actually saved.

      [1] /hippo:namespaces/myhippoproject/newsdocument/hipposysedit:prototypes/hipposysedit:prototype

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                bleunis Bert Leunis (Inactive)
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: