Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-7513

Copy/paste, bookmark of CMS document URL not working with ?1 url parameter

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Top
    • Resolution: Fixed
    • Affects Version/s: 2.26.00
    • Fix Version/s: 2.26.00-alpha-1, 2.26.00
    • Component/s: None
    • Labels:
    • Similar issues:
    • Sprint:
      Sprint 68, Sprint 69

      Description

      Steps to reproduce (firefox)
      1) Login CMS
      2) Go to documents/hippogogreen/events/2010/12/nextgenfuels-2014
      3) Copy the URL: http://cms.demo.test.onehippo.com/?1&path=/content/documents/hippogogreen/events/2010/12/nextgenfuels-2010
      4) Logout
      5) Login again. You will get a session with URL numbering reset to ?1. Stay on the dashboard
      6) Paste the URL / open bookmark to the same site
      Expected: nextgenfuels document is opened.
      Actual: Dashboard keeps open
      Observation: bookmark works as long as the sequence number in the URL is higher than the sequence of the current session. If the bookmarked URL contains a sequence number that is already used changing the url no longer works.
      Observation: The browser back button goes to a previous URL. If the brower was refreshed such that the sequence number is increased going back opens an old page sequence that can result in a 500 error. Exact scenarios TBD

        Attachments

          Activity

            People

            • Assignee:
              abanck Arent-Jan Banck
              Reporter:
              abanck Arent-Jan Banck
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: