Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-11796

Upgrade to Penpal version 3.1.2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 13.2.0
    • Component/s: None
    • Labels:
      None
    • Epic Link:
    • Processed by team:
      Tiger
    • Sprint:
      Tiger Sprint 204

      Description

      The penpal documentation advises to create an iframe element first and add the sandbox attribute before connecting to it. To pass the existing iframe to Penpal is not yet possible in the version we currently use (3.0.3). We should upgrade to version 3.1.2 for this. We also benefit from some bugfixes.

      In the channel manager /frontend-ng/src/app/services/openui.service.js should be updated to match the recommendation from penpal.

      Also the ui-extension library must use this latest version.

      https://www.npmjs.com/package/penpal

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              bleunis Bert Leunis (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: