Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-11430

Pin versions to node '8' and npm '6' and use `npm ci` to install dependencies

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5.1, 5.6.0, 3.2.18, 4.2.15
    • Component/s: None
    • Labels:
      None
    • Processed by team:
      Turing
    • Sprint:
      Turing Sprint 190, Turing Sprint 191

      Description

      In all supported versions in all modules that use package.json:

      We should enforce use of node.js  8.x.x and npm 6.x.x  and use `npm ci` to install dependencies so installs will be reliable and much faster.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jdegooijer Joeri de Gooijer
            Owner:
            Frontend Chapter Frontend Chapter
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: