Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-10227

Saving an empty date field should always result in a placeholder value being set

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0.4
    • Component/s: None
    • Similar issues:
    • Story Points:
      2
    • Processed by team:
      Platform
    • Sprint:
      Platform Sprint 139

      Description

      As discussed in topic: https://groups.google.com/forum/#!topic/hippo-community/6P_ilQ6ftGc

      When a new document containing an empty date is saved through the CMS, the date property on the node is filled with a placeholder value 0001-01-01T13:00:00.000+01:00. However, when a date already has a value and is subsequently emptied through the CMS, then the date property is removed from the node when the document is saved. This is inconsistent behaviour: in both cases an empty date is saved, so in both cases the resulting date value on the node should be equal. As a result, developers have to manage both cases separately in their code where they shouldn't have to.

      Suggestion: change the behaviour so that the placeholder is always used when saving an empty date.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                zzzrbeemsterboer zzzRick Beemsterboer (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: