Uploaded image for project: '[Read Only] - Hippo Repository'
  1. [Read Only] - Hippo Repository
  2. REPO-2190

Multiple site mode breaks concurrent cluster node bootstrap

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • None
    • 13.2.0, 13.1.2
    • None
    • None
    • Pulsar
    • Platform 206 - Content Beans 3, Platform 207 S3DataStore+, Platform 208 13.2+Maint+SSO

    Description

      It appears that attempting to start multiple cluster nodes simultaneously, with all of them using repo.bootstrap=true and using multiple site mode, will almost certainly fail due to concurrent, inconsistent writes to the HCM baseline.

      The obvious workaround options are to 1) don't use repo.startup=true on multiple nodes simultaneously or 2) don't start up multiple nodes at exactly the same time.

      However, we do intend to support multi-node-startup, so we need to build some kind of coordination mechanism to handle this.

      please see attachment file for the detailed logs.

       

      Attachments

        1. cms-logs-v13-1
          32 kB
          Bilal Yasar
        2. site-logs-v13-1
          7 kB
          Bilal Yasar

        Activity

          People

            PCentgraf Peter Centgraf
            byasar Bilal Yasar (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: