Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-7526

Backport Message "Failed to publish HST-configuration" is given, but the action actually ended succesfully

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 2.24.02, 2.26.00
    • Fix Version/s: 2.24.08
    • Component/s: channel-manager
    • Labels:
      None
    • Similar issues:
    • Sprint:
      Sprint 67, Sprint 68

      Description

      After publishing the configuration of a channel in the channel manager, a time out of 30 seconds is used to wait for a response. If the publication process takes more than 30 seconds, the message "Failed to publish HST-configuration" is given. The user thinks something went wrong. Actually this is not necessary the case, the publication succeeds after for example 31 seconds. So then the message is incorrect and confusing.

      A very detailed description and discussion can be found here:

      https://groups.google.com/forum/?hl=en&fromgroups=#!topic/hippo-community/0WCHyEI_p-8

      I guess after time out the message should be something like "Still waiting..." and just extend the time out with another 30 seconds?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jsheriff Junaidh Kadhar Sheriff
                Reporter:
                aschrijvers Ard Schrijvers
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: