Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-5536

Default Gallery processor should not be the default

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.20.02
    • Fix Version/s: 2.20.03
    • Component/s: None
    • Labels:
      None
    • Similar issues:

      Description

      The default gallery processor has been replaced in essence by the ScalingGalleryProcessor, but in practice it is rarely used.
      All projects are supposedly using the ScalingGalleryProcessor as a default, that being apparent from the configuration in node 'hippo:configuration/hippo:frontend/cms/cms-services/galleryProcessorService' and by looking in the GalleryWorkflowPlugin.
      In console, an id is defined with the value being 'service.gallery.processor'. However, the GalleryWorkflowPlugin tries to find the gallery service using the id 'gallery.processor.service'.
      The 2 ids don't match, and the plugin falls back to the DefaultGalleryProcessor.

      Please change the default value in org.hippoecm.frontend.plugins.gallery.GalleryWorkflowPlugin to 'gallery.processor.service' (line 207), so that by default the ScalingGalleryProcessor is used.

        Attachments

          Activity

            People

            • Assignee:
              svoortman Simon Voortman (Inactive)
              Reporter:
              mchatzidakis Minos Chatzidakis
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: