Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-3780

Support for setting hippo:version in initilization to prevent updater execution

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Top
    • Resolution: Fixed
    • Affects Version/s: r2.12.00, r2.12.01
    • Fix Version/s: r2.12.13, r2.15.01
    • Component/s: None
    • Labels:
      None
    • Similar issues:

      Description

      If a project contains an updater module, there is no possibility to prevent this updater from being executed by adding a version tag to /hippo:configuration/hippo:initialize/hippo:version.

      This is particularly needed for the local development environment; starting up the CMS the second time may lead to errors if the content is already up to date.

      A known workaround is to startup with -Drepo.upgrade=false

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jhoffman Jeroen Hoffman
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 4 days, 4 hours
                4d 4h
                Remaining:
                Remaining Estimate - 4 days, 4 hours
                4d 4h
                Logged:
                Time Spent - Not Specified
                Not Specified