Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-9930

[Backport 3.1.5] Login dialog fails after updating to apache tomcat 8.0.30 or 7.0.67

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 10.0.3
    • Fix Version/s: 3.1.5
    • Component/s: None
    • Labels:
    • Environment:
      Debian, Java8, Enterprise-Edition
    • Similar issues:
    • Flagged:
      Flagged

      Description

      After updating from Tomcat 8.0.28 to Tomcat 8.0.30 the login form of cms and console fails with an empty page and a cryptic query:

      http:/XXX/cms/?0-1.IFormSubmitListener-root-login~panel-login~form

      Reverting to Tomcat 8.0.28 or Tomcat 8.29 will fix this issue. But for security reasons we have to update in the near future. So it's a critical bug!

      There is one workaround:
      The log tells that the user is logged in successfully. So, removing the query and reloading the page manually will show the cms oder console as a logged in user. But that is hard to communicate towards the users.

      Possible occasion may be the fix https://bz.apache.org/bugzilla/show_bug.cgi?id=56917 (see release notes of tomcat).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                aschrijvers Ard Schrijvers
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: