Uploaded image for project: 'Hippo CMS'
  1. Hippo CMS
  2. CMS-5305

NPE when creating a new user with wicket logging at DEBUG

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.21.01
    • Component/s: None
    • Labels:
      None
    • Similar issues:

      Description

      When creating a new user, while logging wicket at DEBUG, the following NPE occurs:

      java.lang.NullPointerException
      at org.hippoecm.frontend.plugins.cms.admin.users.DetachableUser.hashCode(DetachableUser.java:60)
      at java.lang.Object.toString(Object.java:219)
      at org.apache.wicket.model.LoadableDetachableModel.toString(LoadableDetachableModel.java:149)
      at java.lang.String.valueOf(String.java:2826)
      at java.lang.StringBuffer.append(StringBuffer.java:219)
      at org.slf4j.helpers.MessageFormatter.deeplyAppendParameter(MessageFormatter.java:237)
      at org.slf4j.helpers.MessageFormatter.arrayFormat(MessageFormatter.java:196)
      at org.slf4j.helpers.MessageFormatter.format(MessageFormatter.java:138)
      at org.slf4j.impl.Log4jLoggerAdapter.debug(Log4jLoggerAdapter.java:246)
      at org.apache.wicket.model.LoadableDetachableModel.detach(LoadableDetachableModel.java:106)

        Attachments

          Activity

            People

            • Assignee:
              jsheriff Junaidh Kadhar Sheriff
              Reporter:
              fvlankvelt Frank van Lankvelt (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: