Uploaded image for project: 'Addon Channel Manager'
  1. Addon Channel Manager
  2. CHANNELMGR-1057

[Back-port to 4.1] render issue in CM for nomarkup components

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 4.1.0
    • Fix Version/s: 4.1.1
    • Labels:
      None
    • Similar issues:
    • Story Points:
      1
    • Sprint:
      Tiger Sprint 145
    • Processed by team:
      Tiger

      Description

      Reproduction path:

      1. create a new archetype project and add simple content
      2. change the contentlist-main-contentlist.ftl to have a single root <div> wrapping the <article> html markup
      3. in the console, find the node /hst:hst/hst:configurations/myhippoproject/hst:workspace/hst:containers/contentlist/main and set xtype=hst.nomarkup
      4. in the cms, from the channel manager, open the page contentlist (click on "content" menu item) in edit mode
      5. there are two placeholders and one component, move the component to the bottom (the one with name "container") and then back to the former (with name "main")

      Result: the component is now shown twice.
      This is "just" a rendering issue. In fact in the backend there is only a single component node created inside workspace. If you navigate to another page in the CM (for example home) and return back, the component will show correctly

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tjeger Tobias Jeger
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: